Forum

Cube 60 Unwanted Di...
 
Notifications
Clear all

Cube 60 Unwanted Distortion  

  RSS

(@mikecullen)
Trusted Member
Joined: 14 years ago
Posts: 82
10/10/2006 2:30 am  

I have a roland cube 60 amp on loan from a friend, who never uses it. I got it home after playing it fine at his house, when i plugged in to the normal jack and the overdrive is turned down all the way, but i still get a little distortion and buzz. I cant seem to fix it! any thoughts?

thanks, mike

"This is a public service announcement....with guitars!"


Quote
(@number6)
Estimable Member
Joined: 15 years ago
Posts: 152
10/10/2006 11:20 pm  

What's the volume like on your guitar? Try turning it down a bit.

The hunger site. Click once a day to give free food.


ReplyQuote
(@slejhamer)
Famed Member
Joined: 16 years ago
Posts: 3341
11/10/2006 1:16 am  

Which amp model do you have it set to?

"Everybody got to elevate from the norm."


ReplyQuote
(@mikecullen)
Trusted Member
Joined: 14 years ago
Posts: 82
11/10/2006 1:46 am  

I tried different amp and guitar volumes, all kinds of combinations didnt work. Slejhammer im sorry for the stupidity but how would i know what amp model its on? It is a 70's vintage model by the way.

"This is a public service announcement....with guitars!"


ReplyQuote
(@forrok_star)
Noble Member
Joined: 17 years ago
Posts: 2340
11/10/2006 2:41 am  

Is you guitar overdriving the input?

Joe


ReplyQuote

Are you on the list? Join for free

Never miss another Guitar Noise lesson again.